Opened 6 years ago

Closed 12 months ago

#5649 defect closed duplicate (duplicate)

twisted.python.sendmsg.send1msg aborts when passed more than one ancillary item

Reported by: Jean-Paul Calderone Owned by:
Priority: low Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

Easy to reproduce, at least on Ubuntu 11.10:

from twisted.python.sendmsg import send1msg
send1msg(0, "foo", 0, [(0, 0, ""), (0, 0, "")])

This will exit with SIGABRT.

It doesn't affect Twisted's usage of send1msg though, so it's not blocking any higher-level functionality we want to expose.

Change History (2)

comment:1 Changed 12 months ago by exvito

Note: #8969 may fix this.

comment:2 Changed 12 months ago by Craig Rodrigues

Resolution: duplicate
Status: newclosed

Duplicate of ticket:8969

Note: See TracTickets for help on using tickets.