Opened 6 years ago

Closed 6 years ago

#5626 defect closed duplicate (duplicate)

LoopingCall possible re-entrancy bug

Reported by: Dev0n Owned by:
Priority: normal Milestone:
Component: core Keywords: LoopingCall re-entrancy
Cc: Branch:
Author:

Description

Getting the following traceback for the code attached. After a conversation with itamar in #twisted, he suggested it that it might be a re-entrancy bug.

The traceback:

2012-04-09 14:50:50+0100 [-] Unhandled Error
  Traceback (most recent call last):
    File "/usr/local/lib/python2.6/dist-packages/Twisted-12.0.0-py2.6-linux-x86_64.egg/twisted/internet/base.py", line 1178, in mainLoop
      self.runUntilCurrent()
    File "/usr/local/lib/python2.6/dist-packages/Twisted-12.0.0-py2.6-linux-x86_64.egg/twisted/internet/base.py", line 800, in runUntilCurrent
      call.func(*call.args, **call.kw)
    File "/usr/local/lib/python2.6/dist-packages/Twisted-12.0.0-py2.6-linux-x86_64.egg/twisted/internet/defer.py", line 368, in callback
      self._startRunCallbacks(result)
    File "/usr/local/lib/python2.6/dist-packages/Twisted-12.0.0-py2.6-linux-x86_64.egg/twisted/internet/defer.py", line 464, in _startRunCallbacks
      self._runCallbacks()
  --- <exception caught here> ---
    File "/usr/local/lib/python2.6/dist-packages/Twisted-12.0.0-py2.6-linux-x86_64.egg/twisted/internet/defer.py", line 551, in _runCallbacks
      current.result = callback(current.result, *args, **kw)
    File "/usr/local/lib/python2.6/dist-packages/Twisted-12.0.0-py2.6-linux-x86_64.egg/twisted/internet/task.py", line 212, in eb
      d.errback(failure)
  exceptions.AttributeError: 'NoneType' object has no attribute 'errback'

Attachments (1)

txLCbug.py (659 bytes) - added by Dev0n 6 years ago.

Download all attachments as: .zip

Change History (2)

Changed 6 years ago by Dev0n

Attachment: txLCbug.py added

comment:1 Changed 6 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Seems very much like a duplicate of #2998.

Note: See TracTickets for help on using tickets.