Opened 6 years ago

Closed 5 years ago

#5592 task closed duplicate (duplicate)

Document purpose and how to run Twisted Web; webguard.py and httpclient.py examples

Reported by: Adwoa Osei-Pianim Owned by: Adwoa Osei-Pianim
Priority: normal Milestone:
Component: web Keywords: documentation
Cc: jesstess, jknight, Thijs Triemstra Branch:
Author:

Description

Document examples in doc/web/examples

Attachments (4)

project.patch (2.8 KB) - added by Adwoa Osei-Pianim 6 years ago.
project.2.patch (1.6 KB) - added by Adwoa Osei-Pianim 6 years ago.
project.3.patch (1.6 KB) - added by Adwoa Osei-Pianim 6 years ago.
project.4.patch (1.3 KB) - added by Adwoa Osei-Pianim 6 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 6 years ago by DefaultCC Plugin

Cc: jknight added

comment:2 Changed 6 years ago by jesstess

Owner: set to Adwoa Osei-Pianim

Changed 6 years ago by Adwoa Osei-Pianim

Attachment: project.patch added

comment:3 Changed 6 years ago by Adwoa Osei-Pianim

Keywords: review added
Owner: Adwoa Osei-Pianim deleted

comment:4 Changed 6 years ago by Thijs Triemstra

Cc: Thijs Triemstra added
Keywords: review removed
Owner: set to Adwoa Osei-Pianim

Thanks for your contribution apianim.

  1. a docstring should be 3 lines or more, a break after the first """ and without the empty line at the end
  2. Instead of ("python httpclient.py <url>"). (or "python webguard.py"), use the general form also used in other examples:
    To run this script:
    python httpclient.py <url>
    
  3. the output in the example can be removed
  4. twisted/web/topfiles/5592.doc's content should be reduced to a single sentence; no header or line breaks etc.

Changed 6 years ago by Adwoa Osei-Pianim

Attachment: project.2.patch added

comment:5 Changed 6 years ago by Adwoa Osei-Pianim

Keywords: review added

Changed 6 years ago by Adwoa Osei-Pianim

Attachment: project.3.patch added

comment:6 Changed 6 years ago by Thijs Triemstra

Keywords: review removed

Thanks for your patch.

Point 1 of my review in comment 4 wasn't addressed. Also this change isn't large enough to require a .doc news file so it can be an empty .misc instead.

Changed 6 years ago by Adwoa Osei-Pianim

Attachment: project.4.patch added

comment:7 Changed 6 years ago by Adwoa Osei-Pianim

Keywords: review added

comment:8 Changed 6 years ago by Thijs Triemstra

Keywords: review removed

Thanks for the patch, apianim. This ticket overlaps with #5612, which was committed to trunk in r34258. Feel free to update your patch against trunk, I think your addition of adding the credentials info at the top of webguard.py is still useful to have. Or close this ticket as a duplicate of #5612.

comment:9 Changed 5 years ago by Thijs Triemstra

Resolution: duplicate
Status: newclosed

Closing as duplicate of #5612, the examples have been documented by now.

Note: See TracTickets for help on using tickets.