Opened 3 years ago

Closed 3 years ago

#5566 defect closed duplicate (duplicate)

AMP over SSH AttributeError - expects getPeer method

Reported by: teratorn Owned by:
Priority: normal Milestone:
Component: conch Keywords: amp ssh
Cc: z3p Branch:
Author: Launchpad Bug:

Description

Trying to run AMP over SSH, and encountered an AttributeError in the process. See attached code to reproduce. Have not yet investigated what the right fix is.

Attachments (1)

ampssh.py (2.5 KB) - added by teratorn 3 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 3 years ago by DefaultCC Plugin

  • Cc z3p added

Changed 3 years ago by teratorn

comment:2 Changed 3 years ago by teratorn

Run server with twistd -noy ampssh.py - generating an id_rsa/id_rsa.pub keypair first - connect on port 2222 (any user/pass) and observe error.

comment:3 Changed 3 years ago by exarkun

  • Resolution set to duplicate
  • Status changed from new to closed

The sample doesn't actually produce any error. Because I already knew this bug was valid, I spent some time investigating, and found that the reason it works is that the example itself monkey-patches the bug away.

That out of the way, this is a duplicate of #2997.

Note: See TracTickets for help on using tickets.