Opened 6 years ago

Closed 6 years ago

#5550 defect closed duplicate (duplicate)

Issues in twisted/protocols/sip.py

Reported by: Thijs Triemstra Owned by: acapnotic
Priority: highest Milestone:
Component: core Keywords:
Cc: Thijs Triemstra Branch:
Author:

Description

  1. #3582 introduced a new deprecation but there are no tests for this deprecation and the version nr is incorrect:
@deprecated(Version("Twisted", 8, 2, 0)) 
  1. The tests were moved but the name wasn't updated:
# -*- test-case-name: twisted.test.test_sip -*-
  1. There are a bunch of deprecated methods that can be removed.

Change History (2)

comment:1 Changed 6 years ago by Jean-Paul Calderone

Priority: highhighest

comment:2 Changed 6 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

I had to re-open #3582 due to test suite regressions, so these issues can be fixed before that branch is re-merged.

Note: See TracTickets for help on using tickets.