Opened 6 years ago

Closed 6 years ago

#5546 defect closed duplicate (duplicate)

IStreamClientEndpointStringParser.parseStreamClient is not passed the reactor

Reported by: habnabit Owned by: habnabit
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch: branches/parseStreamClient-reactor-5546
branch-diff, diff-cov, branch-cov, buildbot
Author: habnabit

Description

This appears to be just an oversight, but neither the interface nor the implementation passes the reactor along. This is kind of important for endpoints.

Change History (8)

comment:1 Changed 6 years ago by habnabit

Author: habnabit
Branch: branches/parseStreamClient-reactor-5546

(In [33768]) Branching to 'parseStreamClient-reactor-5546'

comment:2 Changed 6 years ago by habnabit

(In [33770]) Calling clientFromString with a reactor; updating tests.

Refs #5546.

comment:3 Changed 6 years ago by habnabit

(In [33771]) Adding topfile.

Refs #5546.

comment:4 Changed 6 years ago by habnabit

Keywords: review added
Owner: habnabit deleted

comment:5 Changed 6 years ago by Ying Li

Keywords: review removed
Owner: set to habnabit

Thanks for working on this habnabit!

Looks good to me. Unless something goes hideously wrong with buildbot (unlikely given the scope of the change), please merge.

comment:6 Changed 6 years ago by habnabit

Resolution: fixed
Status: newclosed

(In [33773]) Merge parseStreamClient-reactor-5546: parseStreamClient now receives a reactor

Author: habnabit Reviewer: cyli Fixes: #5546

IStreamClientEndpointStringParser.parseStreamClient now takes a reactor argument, correctly reflecting the docstring on t.i.endpoints.clientFromString.

comment:7 Changed 6 years ago by habnabit

Resolution: fixed
Status: closedreopened

(In [33779]) Revert r33773: Change breaks compatibility policy

This change broke backward compatibility by changing an interface.

Reopens: #5546

comment:8 Changed 6 years ago by habnabit

Resolution: duplicate
Status: reopenedclosed

Duplicate of #5069.

Note: See TracTickets for help on using tickets.