Opened 3 years ago

Closed 3 years ago

#5456 task closed fixed (fixed)

Remove deprecated t.web.twcgi.PHPScripts

Reported by: thijs Owned by: thijs
Priority: low Milestone:
Component: web Keywords:
Cc: thijs, jknight, jesstess Branch: branches/twcgi-php-5456
(diff, github, buildbot, log)
Author: thijs Launchpad Bug:

Description

in trunk/twisted/web/twcgi.py, PHPScript and PHP3Script are deprecated since 10.1 (#516, r28559) and can be removed.

Change History (8)

comment:1 Changed 3 years ago by DefaultCC Plugin

  • Cc jknight added

comment:2 Changed 3 years ago by thijs

  • Owner set to thijs
  • Status changed from new to assigned

comment:3 Changed 3 years ago by thijs

  • Author set to thijs
  • Branch set to branches/twcgi-php-5456

(In [33505]) Branching to 'twcgi-php-5456'

comment:4 Changed 3 years ago by thijs

(In [33506]) removed deprecated FilteredScripts for php, refs #5456

comment:5 Changed 3 years ago by thijs

  • Keywords review added
  • Owner thijs deleted
  • Status changed from assigned to new

comment:6 Changed 3 years ago by jesstess

  • Owner set to jesstess

comment:7 Changed 3 years ago by jesstess

  • Cc jesstess added
  • Keywords review removed
  • Owner changed from jesstess to thijs

Thanks for following up on all these old deprecations, thijs. Looks great, build results are fine, please merge!

comment:8 Changed 3 years ago by thijs

  • Resolution set to fixed
  • Status changed from new to closed

(In [33517]) Merge twcgi-php-5456: Removed deprecated PHP3Script and PHPScript from twisted.web.twcgi. Use twcgi.FilteredScript instead.

Author: thijs
Reviewer: jesstess
Fixes: #5456

Note: See TracTickets for help on using tickets.