Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#5429 task closed fixed (fixed)

Documentation index

Reported by: mesozoic Owned by: mesozoic
Priority: normal Milestone:
Component: core Keywords:
Cc: jesstess Branch: branches/doc-index-5429
branch-diff, diff-cov, branch-cov, buildbot
Author: mesozoic

Description

Says Glyph:

  1. Go to http://twistedmatrix.com/documents/current
  2. Be embarrassed on our behalf.

Let me see if I can improve that a little bit.

This is different than the task to integrate documentation across all of the Twisted modules, so that there is a way to navigate from Twisted Core Documentation back to the documentation index.

Change History (10)

comment:1 Changed 6 years ago by mesozoic

Author: mesozoic
Branch: branches/doc-index-5429

(In [33317]) Branching to 'doc-index-5429'

comment:2 Changed 6 years ago by mesozoic

Keywords: revieiw added
Owner: mesozoic deleted

comment:3 Changed 6 years ago by mesozoic

Keywords: review added; revieiw removed

comment:4 Changed 6 years ago by jesstess

Cc: jesstess added
Owner: set to jesstess

comment:5 Changed 6 years ago by jesstess

Keywords: review removed
Owner: changed from jesstess to mesozoic

Thanks for working on this, mesozoic! This is vastly improved from the current state of the world. A few comments:

  • I'd remove "Documentation" from all of the top-level links, e.g. "Twisted Conch Documentation" ==> "Twisted Conch", since it has both documentation and examples and "Documentation" is already used in a nested link.
  • There are some inconsistencies in the naming:
    • "Twisted.Subproject" and "Twisted Subproject" are variously used
    • "Twisted Words" is sometimes called "Twisted IM"
  • I might just call "Twisted Mail Tutorial: Building an SMTP Client from Scratch" "Twisted Mail Documentation" for parallelism
  • Upgrading is obsolete and shouldn't be linked anywhere (it should get removed, but that can happen in another ticket)

comment:6 Changed 6 years ago by mesozoic

Keywords: review added
Owner: mesozoic deleted

Good suggestions, all of them. Duly committed. Ready for review again.

comment:7 Changed 6 years ago by jesstess

Owner: set to jesstess

comment:8 Changed 6 years ago by jesstess

Keywords: review removed
Owner: changed from jesstess to mesozoic

This looks great, please merge!

comment:9 Changed 6 years ago by mesozoic

Resolution: fixed
Status: newclosed

(In [33398]) Merge doc-index-5429

Author: mesozoic Reviewer: jesstess Fixes: #5429

Add an index page to the documentation tree and make references to "Twisted Products" within the documentation more consistent.

comment:10 Changed 6 years ago by Jean-Paul Calderone

This was a duplicate of #5419. I marked that one as the duplicate, though, since this one is closed already.

Note: See TracTickets for help on using tickets.