Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#5348 enhancement closed duplicate (duplicate)

Use sort(key=...) in SRVConnector

Reported by: Antoine Pitrou Owned by:
Priority: normal Milestone: Python-3.x
Component: names Keywords:
Cc: Antoine Pitrou Branch:
Author:

Description

The cmp argument to list.sort() has been removed in Python 3. Attached patch replaces it with a key argument in twisted.names.srvconnect.SRVConnector.

Attachments (1)

srvconnect_sort.patch (931 bytes) - added by Antoine Pitrou 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by Antoine Pitrou

Attachment: srvconnect_sort.patch added

comment:1 Changed 6 years ago by Antoine Pitrou

Cc: Antoine Pitrou added
Keywords: review added

comment:2 Changed 6 years ago by Thijs Triemstra

Keywords: review removed
Resolution: duplicate
Status: newclosed

Duplicate of #5124. Could you take a look at the patches and work done in that ticket?

comment:3 in reply to:  2 Changed 6 years ago by Antoine Pitrou

Replying to thijs:

Duplicate of #5124. Could you take a look at the patches and work done in that ticket?

I'll try to take a look, but I'm not really motivated to review such patches. My approach is make Twisted work with 3.x, not fix warnings in 2.x.

Note: See TracTickets for help on using tickets.