Ticket #5333 enhancement closed duplicate

Opened 3 years ago

Last modified 3 years ago

Fix gtk reactor test failures on Windows caused by WSAEventSelect's FD_CLOSE behavior

Reported by: exarkun Owned by:
Priority: normal Milestone:
Component: core Keywords: gtk windows
Cc: Branch:
Author: Launchpad Bug:

Description

We discovered a shortcoming in win32eventreactor related to its failure to account for FD_CLOSE only ever being delivered once per socket and fixed it there (#5233). It may be that some of the gtk reactor tests which fail (and are mostly set to skip) on Windows behave as they do for the same reason. We should investigate how gtk exposes close notification to us and whether gtk reactor needs to do something similar to win32eventreactor to keep track of closed, readable connections.

Change History

1

Changed 3 years ago by zseil

gtk does not expose the close notifications on Windows, it has the same shortcoming as win32eventreactor. See the patch and subsequent comments here:  https://bugzilla.gnome.org/show_bug.cgi?id=331214#c13

See also #3371, should that bug be closed?

2

Changed 3 years ago by exarkun

  • status changed from new to closed
  • resolution set to duplicate

This seems like a duplicate of #3371, yea. We close the higher numbered ticket as the duplicate, so closing.

Note: See TracTickets for help on using tickets.