Opened 6 years ago

Closed 4 years ago

#5314 defect closed duplicate (duplicate)

twisted.python.deprecate.deprecated decorator does not print fully qualified name for class methods

Reported by: Ying Li Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

The warning string has the module name and the method name, but not the class name.

e.g. twisted.tap.ftp.opt_password_file rather than twisted.tap.ftp.Options.opt_password_file

Change History (3)

comment:1 Changed 6 years ago by Ying Li

Type: enhancementdefect

comment:2 Changed 6 years ago by Jean-Paul Calderone

This seems related to #3254, to which the resolution was decorating the method object rather than the function object.

comment:3 Changed 4 years ago by Julian Berman

Resolution: duplicate
Status: newclosed

Think this is a duplicate of #4804.

Note: See TracTickets for help on using tickets.