Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#5311 defect closed fixed (fixed)

TLSMemoryBIOFactory logs when it starts and stops, which is unnecessary log spew

Reported by: Itamar Turner-Trauring Owned by: Itamar Turner-Trauring
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

Listening or connecting already has its own logging; additional logging from TLSMemoryBIOFactory is unnecessary, since it will always be wrapping a factory which is the one that will be doing the logging.

Attachments (1)

5311.diff (1.7 KB) - added by Itamar Turner-Trauring 6 years ago.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by Itamar Turner-Trauring

Attachment: 5311.diff added

comment:1 Changed 6 years ago by Itamar Turner-Trauring

Keywords: review added

comment:2 Changed 6 years ago by Jean-Paul Calderone

Keywords: review removed
Owner: set to Itamar Turner-Trauring

Awesome, thanks, please apply!

comment:3 Changed 6 years ago by itamarst

Resolution: fixed
Status: newclosed

(In [32852]) Get rid of too much logging in TLSMemoryBIOFactory.

Author: itamar Review: exarkun Fixes: #5311

comment:4 Changed 6 years ago by rlotun

For the record, this was a duplicate of an existing ticket (which I'll close): #5073

comment:5 Changed 6 years ago by Jean-Paul Calderone

Oops! Thanks for noticing. :)

Note: See TracTickets for help on using tickets.