Opened 3 years ago

Last modified 3 years ago

#5297 defect reopened

twistd pidfile and UID/GID privileges

Reported by: tomsheffler Owned by:
Priority: normal Milestone:
Component: core Keywords: twistd pidfile
Cc: Branch:
Author: Launchpad Bug:

Description

When twistd starts as root, and is asked to drop privileges to UID/GID, it will manage the pidfile in the following way

  • the pidfile will be created as root
  • upon exit, the pidfile will be removed by a process with privileges of UID/GID

The current implementation places some unexpected on setting up the pidfile directory: it must be writable by UID/GID or the pidfile is not removed.

This behavior is mysterious and unexpected. At the least it should be documented.

See here for more details: http://www.tsheffler.com/blog/?p=526

Change History (2)

comment:1 follow-up: Changed 3 years ago by thijs

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5296

comment:2 in reply to: ↑ 1 Changed 3 years ago by thijs

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Replying to thijs:

Duplicate of #5296

Oops my bad, not a duplicate.

Note: See TracTickets for help on using tickets.