Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#5222 defect closed duplicate (duplicate)

twisted.internet.interfaces.IReactorProcess.spawnProcess documentation

Reported by: cpburns Owned by:
Priority: low Milestone:
Component: core Keywords: spawnProcess, documentation
Cc: Branch:
Author:

Description

On linux (Ubuntu) running Twisted 11.0.0 with Python 2.6, if the file being referenced by executable lacks executable permissions, an OSError with errno EACCES (13) is raised. The documentation for the spawnProcess function does not mention this error. It only mentions an OSError with EAGAIN and ENOMEM if there's not enough system resources.

http://twistedmatrix.com/documents/current/api/twisted.internet.interfaces.IReactorProcess.spawnProcess.html

Change History (2)

comment:1 Changed 6 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Thanks. This is a duplicate of #2728.

comment:2 Changed 6 years ago by Jean-Paul Calderone

I mean #2787.

Note: See TracTickets for help on using tickets.