Opened 6 years ago

Closed 6 years ago

#5195 defect closed duplicate (duplicate)

shouldn't send content-type: text/html for 304 not modified

Reported by: Martin Pool Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

For background, see <https://bugs.launchpad.net/pyopenssl/+bug/703807>.

twisted.web has a default for responses of content-type text/html, which is probably reasonable. However, it ends up also sending this header for 304 requests which is problematic, because caches must update their cache headers with the result.

It seems like a more reasonable default would be not to send content-type on 304 responses

Change History (1)

comment:1 Changed 6 years ago by Martin Pool

Resolution: duplicate
Status: newclosed

duplicate of ticket 4156

Note: See TracTickets for help on using tickets.