Opened 6 years ago

Closed 6 years ago

#5177 enhancement closed duplicate (duplicate)

Make inlineCallbacks more proeminent in the docs

Reported by: Leonardo Santagada Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

inlineCallbacks is more or less what has been reinvented many times in the python community and I think it is partially because it is buried in the twisted documentation.

There should be a way to show inlineCallbacks to new users to show that you can do asynchronous communication without using callbacks everywhere. In the last pycon(2011) guido himself told that he doesn't understand callback based code and that he thinks the future of async in python is using generators, so I really think this is something the twisted community should talk about.

Change History (1)

comment:1 Changed 6 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

This seems like a duplicate of #1009 to me.

Note: See TracTickets for help on using tickets.