Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#5172 enhancement closed duplicate (duplicate)

Twisted compatibility policy should enumerate which test methods are preferred

Reported by: Ying Li Owned by:
Priority: normal Milestone:
Component: website Keywords: documentation
Cc: oubiwann Branch:
Author:

Description

It seems, from reading reviews, that certain tests methods are preferred over others. For instance, assertEqual (may?) be slightly preferred over assertEquals, which is preferred over failUnlessTrue.

Such preferences should probably be enumerated in the Twisted Coding Standard or elsewhere.

Change History (3)

comment:1 Changed 6 years ago by DefaultCC Plugin

Cc: oubiwann added

comment:2 Changed 6 years ago by Ying Li

Resolution: duplicate
Status: newclosed

comment:3 Changed 6 years ago by Ying Li

duplicate of #4989

Note: See TracTickets for help on using tickets.