Opened 6 years ago

Closed 6 years ago

#5162 enhancement closed duplicate (duplicate)

getPlugins inspection and debugging tool

Reported by: Glyph Owned by: Jonathan Lange
Priority: normal Milestone:
Component: core Keywords:
Cc: Thijs Triemstra Branch:
Author:

Description

When getPlugins can't find your plugin, it's confusing. There should be a tool which prints an easy-to-read summary of where getPlugins looked for a particular interface/package pair, and why it looked there. Better still would be for such a tool to inspect plugin modules for common errors, the biggest one being "you implemented a plugin but you didn't instantiate a provider", but also things like "you made some classes but none of them implement this interface".

Change History (2)

comment:1 Changed 6 years ago by Thijs Triemstra

Cc: Thijs Triemstra added

This looks like a duplicate of #5039?

comment:2 Changed 6 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.