Opened 7 years ago

Closed 7 years ago

#5041 enhancement closed duplicate (duplicate)

Patch to fix and normalize preambles

Reported by: anatoly techtonik Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

As mwh pointed in comment:4:ticket:5019 preambles do not match coding standard. This patch not only normalizes them, but also fixes detection when checkout is made into /twisted/ or /MyTwisted/ or /MyTwistedTrunk/, but not /Twisted*/.

There is only one piece of code I don't completely understand:

if not hasattr(os, "getuid") or os.getuid() != 0:
    sys.path.insert(0, os.getcwd())

Attachments (3)

normalize.preamble.patch (15.9 KB) - added by anatoly techtonik 7 years ago.
normalize.preamble.2.patch (16.0 KB) - added by anatoly techtonik 7 years ago.
better version
normalize.preamble.3.patch (15.9 KB) - added by anatoly techtonik 7 years ago.
trailing space

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by anatoly techtonik

Attachment: normalize.preamble.patch added

comment:1 Changed 7 years ago by anatoly techtonik

Keywords: review added

comment:2 Changed 7 years ago by Jean-Paul Calderone

Keywords: review removed
Resolution: duplicate
Status: newclosed

This is a duplicate of #3526.

Changed 7 years ago by anatoly techtonik

Attachment: normalize.preamble.2.patch added

better version

Changed 7 years ago by anatoly techtonik

Attachment: normalize.preamble.3.patch added

trailing space

Note: See TracTickets for help on using tickets.