Opened 7 years ago

Closed 7 years ago

#4971 enhancement closed duplicate (duplicate)

Endpoints don't have __repr__ functions

Reported by: Stephen Thorne Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

It would be good if you print a TCP4ClientEndpoint it would show what host, port, timeout, bindaddress and protocol it may be associated with it.

Each of the public classes returned from twisted.internet.endpoints.{server,client}FromString() should have a useful repr function.

Change History (1)

comment:1 Changed 7 years ago by Stephen Thorne

Resolution: duplicate
Status: newclosed

Duplicate of #4970

Note: See TracTickets for help on using tickets.