Opened 7 years ago

Closed 5 years ago

#4970 enhancement closed duplicate (duplicate)

Endpoints don't have __repr__ functions

Reported by: Stephen Thorne Owned by:
Priority: normal Milestone:
Component: core Keywords: easy
Cc: Thijs Triemstra Branch:
Author:

Description

It would be good if you print a TCP4ClientEndpoint it would show what host, port, timeout, bindaddress and protocol it may be associated with it.

Each of the public classes returned from twisted.internet.endpoints.{server,client}FromString() should have a useful repr function.

Change History (3)

comment:1 Changed 5 years ago by Thijs Triemstra

Cc: Thijs Triemstra added

comment:2 Changed 5 years ago by Julian Berman

Keywords: easy added

comment:3 Changed 5 years ago by Julian Berman

Resolution: duplicate
Status: newclosed

#5633 is a duplicate of this, but closing this since that has some activity and patches.

Note: See TracTickets for help on using tickets.