Opened 7 years ago

Closed 7 years ago

#4950 defect closed duplicate (duplicate)

win32eventreactor versions of some twisted.internet tests take 30 seconds to run

Reported by: PenguinOfDoom Owned by: PenguinOfDoom
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

twisted.internet.test.test_tcp.TCPClientTestsBuilder_Win32Reactor.test_unregisterProducerAfterDisconnect

twisted.internet.test.test_tls.SSLClientTestsMixin_Win32Reactor.test_disconnectAfterWriteAfterStartTLS

win32eventreactor mainloop first runs some event handlers, then goes into WaitForMultipleObjects without checking if reactor has been stopped by those handlers

Change History (2)

comment:1 Changed 7 years ago by zseil

I think that the problem lies elsewhere, win32eventreactor keeps spinning because it doesn't notice that the connection has been gracefully shut down (it would have to use WSAEnumNetworkEvents to distinguish regular read notifications from shutdown notifications and keep calling doRead in the latter case until the final empty recv).

It also looks like this issue is a duplicate of #3824, one of them can be closed.

comment:2 in reply to:  1 Changed 7 years ago by Thijs Triemstra

Resolution: duplicate
Status: newclosed

Replying to zseil:

It also looks like this issue is a duplicate of #3824, one of them can be closed.

Agreed.

Note: See TracTickets for help on using tickets.