Opened 3 years ago

Closed 3 years ago

#4910 defect closed duplicate (duplicate)

No indication that error comes from log.err

Reported by: jml Owned by:
Priority: normal Milestone:
Component: trial Keywords:
Cc: jml Branch:
Author: Launchpad Bug:

Description

Just helping someone debug a failing test, got this error:

[ERROR]
Traceback (most recent call last):
Failure: twisted.protocols.ftp.IsNotADirectoryError: blah

twisted.test.test_ftp.FTPServerTestCaseAdvancedClient.test_STORwriteError

Turns out that the error comes from a call to log.err. There's no hint of this in the error message, and error messages from tests are supposed to help you isolate errors.

Change History (2)

comment:1 Changed 3 years ago by DefaultCC Plugin

  • Cc jml added

comment:2 Changed 3 years ago by zseil

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #4396. jml, I can't add you to CC list on that bug so please add yourself if you are still interested in tracking this issue.

Note: See TracTickets for help on using tickets.