Opened 7 years ago

Closed 7 years ago

#4829 defect closed duplicate (duplicate)

gtk2reactor consumes all CPU after reactor.spawnProcess is called from UI

Reported by: Antoine Martin Owned by:
Priority: high Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

I originally thought that this was #3096 as the symptom is exactly the same, but since those gtk/glib reactor integration bugs have been fixed upstream, it looks like something else is at play here.

I'm attaching a trivial test case that shows the problem on all versions of Fedora (since at least Fedora 12) and all recent versions of Ubuntu/Debian. Note: this does not occur on MS Windows as far as I can tell. I am at a loss to explain why I am the first one to report this, am I doing something fundamentally wrong here? A workaround would be most helpful.

Attachments (1)

cpuhog.py (939 bytes) - added by Antoine Martin 7 years ago.
test case which ends up consuming all available CPU for no good reason

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by Antoine Martin

Attachment: cpuhog.py added

test case which ends up consuming all available CPU for no good reason

comment:1 Changed 7 years ago by Jean-Paul Calderone

Keywords: cpu removed
Milestone: regular-releases
Resolution: duplicate
Status: newclosed

Duplicate of #4658.

comment:2 Changed 7 years ago by <automation>

Note: See TracTickets for help on using tickets.