Opened 7 years ago

Closed 7 years ago

#4816 defect closed duplicate (duplicate)

twistd --uid without --gid breaks

Reported by: Tyler Hobbs Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

Twisted 10.1.0 Linux thobbs-laptop 2.6.35-23-generic #41-Ubuntu SMP Wed Nov 24 11:55:36 UTC 2010 x86_64 GNU/Linux

Python 2.6.6

Twisted was installed via the python-twisted package.

When running twistd with the --uid option but without --gid, I get an exception with the attached traceback.

Basically, the docstring for twisted.python.util.initgroups() indicates that the _initgroups C extension accepts a C{int} or a C{NoneType} can be accepted for the gid, but _initgroups.c appears to only accept an unsigned integer, not None. This problem goes away when --gid is supplied.

I checked twisted.python.util.py and the _initgroups C extension in subversion and nothing seems to have changed in this area.

Attachments (1)

traceback.txt (1.9 KB) - added by Tyler Hobbs 7 years ago.

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by Tyler Hobbs

Attachment: traceback.txt added

comment:1 Changed 7 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Duplicate of #4442.

comment:2 Changed 7 years ago by <automation>

Owner: Glyph deleted
Note: See TracTickets for help on using tickets.