Opened 7 years ago

Closed 7 years ago

#4807 enhancement closed duplicate (duplicate)

Update robots.txt to block non-current API listings, add links to older API documentation from Documentation page

Reported by: Itamar Turner-Trauring Owned by:
Priority: normal Milestone:
Component: website Keywords:
Cc: Branch:
Author:

Description

Google results often return API documentation from 9.0 or 10.1. Ideally they'd always point to the current documentation. To do so, we should have robots.txt block access to older versions of the API documentation.

Since some people might want to see them nonetheless, we could add links to older API docs from the Documentation wiki page, for the benefit of human readers.

Change History (2)

comment:1 Changed 7 years ago by Glyph

Resolution: duplicate
Status: newclosed

This looks like a duplicate of #4656, at least in what it's trying to do - the main point is to direct searchers to the new documentation rather than the old documentation.

Personally I don't think that robots.txt is the right way to go. People might want to search for the "old" documentation (which may be current on their platform or for their project) by explicitly searching for a version number, and robots.txt will break that. My understanding is that if we include these entries in robots.txt, we'll lose all of the PageRank score associated with the inbound links to old documentation, whereas if we just link from the old to new, the ranking will flow through to the new version.

comment:2 Changed 7 years ago by <automation>

Owner: oubiwann deleted
Note: See TracTickets for help on using tickets.