Opened 7 years ago

Closed 7 years ago

#4768 enhancement closed duplicate (duplicate)

twisted.web.client should have a FileProducer to work with new Agent

Reported by: Drew Smathers Owned by: Drew Smathers
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

Streaming uploads is possible with the new client but it's kind of tedious because currently you have to craft your own IBodyProducer implementation to do this. Reusing twisted.protocols.basic.FileSender isn't exactly possible either because it tries to register and unregister producers on a proxying consumer and this is bad (see #4660).

Twisted should have a simple IBodyConsumer implementation FileProducer in client that works similarly to FileSender.

Change History (3)

comment:1 Changed 7 years ago by Drew Smathers

Summary: twisted.web.client should have a `FileProducer` to work with new `Agent`twisted.web.client should have a FileProducer to work with new Agent

comment:2 Changed 7 years ago by Drew Smathers

Status: newassigned

comment:3 Changed 7 years ago by Drew Smathers

Resolution: duplicate
Status: assignedclosed

duplicate of #4017

Note: See TracTickets for help on using tickets.