Opened 4 years ago

Closed 4 years ago

#4721 defect closed invalid (invalid)

Zope error

Reported by: Theo_M Owned by:
Priority: normal Milestone:
Component: core Keywords: zope
Cc: Branch:
Author: Launchpad Bug:

Description

I just started with the book 'Twisted network programming essentials'
I use Python 3.1 and try to correct for version differences.
Running the script:
from twisted.internet import reactor
print("Running the reactor")
reactor.run()
print("reactor stopped")

I get the AttributeError:'function' object has no attribute 'func_defaults' with file reference:
zope\interface\interface.py", line 765, in fromFunction defaults = func.func_defaults or ()

It looks the function passed at that moment is queryTaggedValue

Does anyone have any suggestions?

Change History (2)

comment:1 Changed 4 years ago by exarkun

  • Resolution set to invalid
  • Status changed from new to closed

Python 3.x is not supported by any current version of Twisted. It looks like the particular error you ran into first is actually caused by lack of Python 3.x support in the version of zope.interface you have installed, though.

Switch to a version of Python between 2.4 and 2.7 (inclusive) for further Twisted learning. :)

comment:2 Changed 3 years ago by <automation>

  • Owner glyph deleted
Note: See TracTickets for help on using tickets.