Opened 7 years ago

Closed 7 years ago

#4648 defect closed duplicate (duplicate)

spawnProcess return value does not always implement IProcessTransport

Reported by: spiv Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

The spawnProcess docstring claims that it returns an IProcessTransport provider. However PosixReactorBase.spawnProcess can return twisted.internet.process.Process and twisted.internet.process.PTYProcess, neither of which implements() that interface.

Probably what should be done is simply add implements declarations to those two classes. A reasonable test may be to invoke spawnProcess and call zope.interface.verify.verifyObject(IProcessTransport, obj) on the result.

(I'm reporting this on behalf of John Arbash Meinel)

Change History (2)

comment:1 Changed 7 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Duplicate of #4585

comment:2 Changed 7 years ago by <automation>

Owner: Glyph deleted
Note: See TracTickets for help on using tickets.