Opened 7 years ago

Closed 7 years ago

#4615 defect closed duplicate (duplicate)

insults.window.ScrolledArea is unusable: TypeError on __init__

Reported by: Kaedenn Owned by:
Priority: normal Milestone:
Component: conch Keywords: conch insults window TypeError __init__
Cc: Branch:
Author: kaedenn

Description

When running the window.tac example (slightly modified, see attached), I got the following traceback upon successful login (see attached). This is caused by Widget not having init defined, so TypeError is thrown when ScrolledArea calls Widget.init(self, containee).

This made ScrolledArea completely unusable.

There are two obvious fixes: implement Widget.init or remove the containee argument.

Attached is a patch implementing the latter.

Attachments (3)

window.py.diff (481 bytes) - added by Kaedenn 7 years ago.
Patch for window.py
window.tac.diff (454 bytes) - added by Kaedenn 7 years ago.
Change to window.tac; may not be significant
traceback (1.7 KB) - added by Kaedenn 7 years ago.
Error when using ScrolledArea

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by Kaedenn

Attachment: window.py.diff added

Patch for window.py

Changed 7 years ago by Kaedenn

Attachment: window.tac.diff added

Change to window.tac; may not be significant

Changed 7 years ago by Kaedenn

Attachment: traceback added

Error when using ScrolledArea

comment:1 Changed 7 years ago by Jean-Paul Calderone

Milestone: regular-releases
Resolution: duplicate
Status: newclosed

Duplicate of #4197

comment:2 Changed 7 years ago by <automation>

Owner: z3p deleted
Note: See TracTickets for help on using tickets.