Ticket #4575 enhancement closed fixed

Opened 4 years ago

Last modified 4 years ago

Improve lore2sphinx buildbot results for `projects/vfs`

Reported by: khorn Owned by:
Priority: normal Milestone: Lore to Sphinx
Component: core Keywords:
Cc: Branch: branches/improve-lore2sphinx-output-for-projects-vfs-4575
(diff, github, buildbot, log)
Author: khorn Launchpad Bug:

Description

like #4566, except for projects/vfs

Change History

1

Changed 4 years ago by glyph

  • summary changed from Improve lore2sphinx buildbot results for `projects/conch` to Improve lore2sphinx buildbot results for `projects/vfs`

2

Changed 4 years ago by khorn

  • owner changed from glyph to khorn

3

Changed 4 years ago by khorn

  • branch set to branches/improve-lore2sphinx-output-for-projects-vfs-4575
  • branch_author set to khorn

(In [29882]) Branching to 'improve-lore2sphinx-output-for-projects-vfs-4575'

4

Changed 4 years ago by khorn

  • keywords review added
  • owner khorn deleted

There's almost nothing to do here as far as existing markup, however, the links in examples/index.xhtml don't actually go anywhere. Since the examples are all made up of multiple files, it doesn't make sense to point to any single file, but there's no existing documentation that ties the various files for the examples together.

So, do we do nothing and add this "chunk" as is? Or do we add an index file in Lore format to the existing examples/vfsapp and examples/welsh directories?

And if we do want to add those Lore index files, should they be added under this ticket, or another one?

[sending this to review in the hopes that someone will comment...even though nothing has actually been done yet]

5

Changed 4 years ago by exarkun

  • owner set to khorn
  • keywords review removed

One thing to note is that we don't publish the vfs docs on the website. So no matter what we do, there's no regression. Another thing to note is that vfs seems largely abandoned, and at least a few long-time Twisted developers don't agree that vfs is the right direction to be taking development in order to accomplish the goals it sets out to accomplish. So writing new documentation for it seems like a poor use of time. Perhaps the important thing to address is to be sure the vfs docs aren't published after the sphinx conversion, either (likewise for web2).

6

Changed 4 years ago by khorn

  • status changed from new to closed
  • resolution set to fixed

In that case, I guess we'll consider this one to be fixed

If anyone seriously disagrees, either reopen or file a new ticket.

7

Changed 4 years ago by khorn

  • milestone set to Lore to Sphinx

8

Changed 3 years ago by <automation>

  • owner khorn deleted
Note: See TracTickets for help on using tickets.