Opened 4 years ago

Closed 4 years ago

#4557 enhancement closed duplicate (duplicate)

Support setting the rotateLength parameter to None from twistd

Reported by: robertc Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

twistd -l foo.log sets a log file called foo.log which external rotation can be done on by 'mv foo.log rotated.log; kill -USR1 $(< twisted.pid)'.

This is great but it leaves autorotation on, which makes this a bit messy.

It would be really nice if there was a way to completely disable log rotation from the twistd command line. E.g.

twistd -l foo.log --rotate-at=None

This would pass through to the LogFile.fromFullPath() function, and need to translate 'None' to None.

Sadly I don't know the twistd command line glue stuff, because this seems conceptually trivial, and it would be really really useful :)

Change History (2)

comment:1 Changed 4 years ago by exarkun

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3363

comment:2 Changed 4 years ago by <automation>

  • Owner glyph deleted
Note: See TracTickets for help on using tickets.