Opened 8 years ago

Closed 8 years ago

#4493 defect closed duplicate (duplicate)

Web server request does not handle POST URL PROTOCOL

Reported by: cr3 Owned by:
Priority: high Milestone:
Component: web Keywords:
Cc: Branch:
Author:

Description

In twisted/web/http.py, Request.process contains the following code:

self.postpath = map(unquote, string.split(self.path[1:], '/'))

So, if self.path is assigned a URL (eg, http://localhost/foo) rather than just a path (/foo), then the resulting postpath doesn't make any sense.

Change History (2)

comment:1 Changed 8 years ago by ivank

Resolution: duplicate
Status: newclosed

duplicate of #4371

comment:2 Changed 7 years ago by <automation>

Owner: jknight deleted
Note: See TracTickets for help on using tickets.