Opened 8 years ago

Closed 8 years ago

#4484 defect closed duplicate (duplicate)

twisted.mail.smtp still imports MimeWriter

Reported by: ChrisW Owned by:
Priority: normal Milestone:
Component: mail Keywords:
Cc: Branch:
Author:

Description

This has been deprecated since Python 2.3, it should no longer be used, the email package should be used instead.

The current state of affairs gives ugly DeprecationWarnings whenever you use a module that imports twisted.mail.smtp:

Twisted-10.0.0-py2.6-linux-x86_64.egg/twisted/mail/smtp.py:10: DeprecationWarning: the MimeWriter module is deprecated; use the email package instead

import MimeWriter, tempfile, rfc822

Change History (2)

comment:1 Changed 8 years ago by therve

Resolution: duplicate
Status: newclosed

Duplicate of #4038.

comment:2 Changed 7 years ago by <automation>

Owner: Jean-Paul Calderone deleted
Note: See TracTickets for help on using tickets.