Opened 4 years ago

Closed 4 years ago

#4466 regression closed duplicate (duplicate)

test_process failures on Debian

Reported by: mithrandi Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

I get the following failures on Debian sid (unstable) amd64:

===============================================================================
[FAIL]: twisted.internet.test.test_process.PTYProcessTestsBuilder_PollReactor.test_systemCallUninterruptedByChildExit

Traceback (most recent call last):
  File "/home/mithrandi/code/Twisted/trunk/twisted/internet/test/test_process.py", line 219, in test_systemCallUninterruptedByChildExit
    self.assertEqual(result, ["Foo\n"])   
twisted.trial.unittest.FailTest: not equal:
a = []
b = ['Foo\n']

===============================================================================
[FAIL]: twisted.internet.test.test_process.PTYProcessTestsBuilder_SelectReactor.test_systemCallUninterruptedByChildExit

Traceback (most recent call last):
  File "/home/mithrandi/code/Twisted/trunk/twisted/internet/test/test_process.py", line 219, in test_systemCallUninterruptedByChildExit
    self.assertEqual(result, ["Foo\n"])   
twisted.trial.unittest.FailTest: not equal:
a = []
b = ['Foo\n']

===============================================================================
[FAIL]: twisted.internet.test.test_process.ProcessTestsBuilder_PollReactor.test_systemCallUninterruptedByChildExit

Traceback (most recent call last):
  File "/home/mithrandi/code/Twisted/trunk/twisted/internet/test/test_process.py", line 219, in test_systemCallUninterruptedByChildExit
    self.assertEqual(result, ["Foo\n"])
twisted.trial.unittest.FailTest: not equal:
a = []
b = ['Foo\n']

===============================================================================
[FAIL]: twisted.internet.test.test_process.ProcessTestsBuilder_SelectReactor.test_systemCallUninterruptedByChildExit

Traceback (most recent call last):
  File "/home/mithrandi/code/Twisted/trunk/twisted/internet/test/test_process.py", line 219, in test_systemCallUninterruptedByChildExit
    self.assertEqual(result, ["Foo\n"])
twisted.trial.unittest.FailTest: not equal:
a = []
b = ['Foo\n']

===============================================================================
[ERROR]: twisted.internet.test.test_process.PTYProcessTestsBuilder_PollReactor.test_systemCallUninterruptedByChildExit

Traceback (most recent call last):
  File "/home/mithrandi/code/Twisted/trunk/twisted/internet/base.py", line 426, in _continueFiring
    callable(*args, **kwargs)
  File "/home/mithrandi/code/Twisted/trunk/twisted/internet/test/test_process.py", line 213, in f
    result.append(f2.read())
exceptions.IOError: [Errno 4] Interrupted system call
===============================================================================
[ERROR]: twisted.internet.test.test_process.PTYProcessTestsBuilder_SelectReactor.test_systemCallUninterruptedByChildExit

Traceback (most recent call last):
  File "/home/mithrandi/code/Twisted/trunk/twisted/internet/base.py", line 426, in _continueFiring
    callable(*args, **kwargs)
  File "/home/mithrandi/code/Twisted/trunk/twisted/internet/test/test_process.py", line 213, in f
    result.append(f2.read())
exceptions.IOError: [Errno 4] Interrupted system call
===============================================================================
[ERROR]: twisted.internet.test.test_process.ProcessTestsBuilder_PollReactor.test_systemCallUninterruptedByChildExit

Traceback (most recent call last):
  File "/home/mithrandi/code/Twisted/trunk/twisted/internet/base.py", line 426, in _continueFiring
    callable(*args, **kwargs)
  File "/home/mithrandi/code/Twisted/trunk/twisted/internet/test/test_process.py", line 213, in f
    result.append(f2.read())
exceptions.IOError: [Errno 4] Interrupted system call
===============================================================================
[ERROR]: twisted.internet.test.test_process.ProcessTestsBuilder_SelectReactor.test_systemCallUninterruptedByChildExit

Traceback (most recent call last):
  File "/home/mithrandi/code/Twisted/trunk/twisted/internet/base.py", line 426, in _continueFiring
    callable(*args, **kwargs)
  File "/home/mithrandi/code/Twisted/trunk/twisted/internet/test/test_process.py", line 213, in f
    result.append(f2.read())
exceptions.IOError: [Errno 4] Interrupted system call
===============================================================================

I have no clue what any of them mean, but I'd be happy to provide assistance in tracking down the cause; catch me on IRC as "idnar".

Change History (2)

comment:1 Changed 4 years ago by exarkun

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4331

comment:2 Changed 3 years ago by <automation>

  • Owner glyph deleted
Note: See TracTickets for help on using tickets.