Opened 8 years ago

Closed 8 years ago

#4425 defect closed duplicate (duplicate)

twisted.conch.test fails Trial on Ubuntu 10.04

Reported by: Brian Arita Owned by:
Priority: normal Milestone:
Component: conch Keywords:
Cc: Branch:
Author:

Description (last modified by Glyph)

On both the 64-bit and 32-bit versions:

===============================================================================
[ERROR]: twisted.conch.test.test_cftp.TestOurServerSftpClient.test_extendedAttributes

Traceback (most recent call last):
  File "/var/lib/buildbot/twisted/lucid64-python2.6-select/Twisted/twisted/internet/selectreactor.py", line 146, in _doReadOrWrite
    why = getattr(selectable, method)()
  File "/var/lib/buildbot/twisted/lucid64-python2.6-select/Twisted/twisted/internet/tcp.py", line 460, in doRead
    return self.protocol.dataReceived(data)
  File "/var/lib/buildbot/twisted/lucid64-python2.6-select/Twisted/twisted/conch/ssh/transport.py", line 313, in dataReceived
    self.dispatchMessage(messageNum, packet[1:])
  File "/var/lib/buildbot/twisted/lucid64-python2.6-select/Twisted/twisted/conch/ssh/transport.py", line 328, in dispatchMessage
    f(payload)
  File "/var/lib/buildbot/twisted/lucid64-python2.6-select/Twisted/twisted/conch/ssh/transport.py", line 421, in ssh_DISCONNECT
    self.receiveError(reasonCode, description)
  File "/var/lib/buildbot/twisted/lucid64-python2.6-select/Twisted/twisted/conch/test/test_ssh.py", line 330, in receiveError
    (self, reasonCode, desc))
  File "/var/lib/buildbot/twisted/lucid64-python2.6-select/Twisted/twisted/trial/unittest.py", line 1575, in _
    return getattr(_inst, name)(*args, **kwargs)
twisted.trial.unittest.FailTest: got disconnect for <twisted.conch.test.test_ssh.ConchTestServer instance at 0x5b8b878>: reason 11, desc: disconnected by user
===============================================================================
[ERROR]: twisted.conch.test.test_conch.OpenSSHClientTestCase.test_exec

Traceback (most recent call last):
  File "/var/lib/buildbot/twisted/lucid64-python2.6-select/Twisted/twisted/internet/selectreactor.py", line 146, in _doReadOrWrite
    why = getattr(selectable, method)()
  File "/var/lib/buildbot/twisted/lucid64-python2.6-select/Twisted/twisted/internet/tcp.py", line 460, in doRead
    return self.protocol.dataReceived(data)
  File "/var/lib/buildbot/twisted/lucid64-python2.6-select/Twisted/twisted/conch/ssh/transport.py", line 313, in dataReceived
    self.dispatchMessage(messageNum, packet[1:])
  File "/var/lib/buildbot/twisted/lucid64-python2.6-select/Twisted/twisted/conch/ssh/transport.py", line 328, in dispatchMessage
    f(payload)
  File "/var/lib/buildbot/twisted/lucid64-python2.6-select/Twisted/twisted/conch/ssh/transport.py", line 421, in ssh_DISCONNECT
    self.receiveError(reasonCode, description)
  File "/var/lib/buildbot/twisted/lucid64-python2.6-select/Twisted/twisted/conch/test/test_ssh.py", line 330, in receiveError
    (self, reasonCode, desc))
  File "/var/lib/buildbot/twisted/lucid64-python2.6-select/Twisted/twisted/trial/unittest.py", line 1575, in _
    return getattr(_inst, name)(*args, **kwargs)
twisted.trial.unittest.FailTest: got disconnect for <twisted.conch.test.test_ssh.ConchTestServer instance at 0x5cbaa28>: reason 11, desc: disconnected by user
-------------------------------------------------------------------------------

http://buildbot.twistedmatrix.com/builders/lucid64-py2.6-select/builds/0/steps/trial/logs/problems

Change History (3)

comment:1 Changed 8 years ago by Glyph

Description: modified (diff)

Just formatting.

comment:2 Changed 8 years ago by Glyph

Resolution: duplicate
Status: newclosed

#4454 (which is now fixed) was a duplicate of this.

comment:3 Changed 7 years ago by <automation>

Owner: z3p deleted
Note: See TracTickets for help on using tickets.