Opened 8 years ago

Closed 8 years ago

#4381 defect closed duplicate (duplicate)

MimeWriter is deprecated, so twisted.mail.smtp should move the import into sendEmail( ) (or just not use MimeWriter)

Reported by: Morgen Sagen Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

Anyone importing twisted.mail.smtp is greeted with:

"twisted/mail/smtp.py:10: DeprecationWarning: the MimeWriter module is deprecated; use the email package instead"

MimeWriter is deprecated, so twisted.mail.smtp should move the import into sendEmail( ) (or just not use MimeWriter)

Change History (4)

comment:1 Changed 8 years ago by Glyph

Status: newassigned

comment:2 Changed 8 years ago by Glyph

Type: enhancementdefect

comment:3 Changed 8 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: assignedclosed

Duplicate of #4038.

comment:4 Changed 7 years ago by <automation>

Owner: Glyph deleted
Note: See TracTickets for help on using tickets.