Opened 8 years ago

Closed 8 years ago

#4333 defect closed wontfix (wontfix)

build-apidocs doesn't work with pydoctor 0.2-4ubuntu1

Reported by: Jonathan Lange Owned by:
Priority: normal Milestone:
Component: release management Keywords:
Cc: Branch:
Author:

Description

$ ./bin/admin/build-apidocs . /tmp/twisted-release/
/home/jml/src/Twisted/branches/release-x-4290/twisted/python/_release.py:25: DeprecationWarning: The popen2 module is deprecated.  Use the subprocess module.
  from popen2 import Popen4
/usr/lib/pymodules/python2.6/pydoctor/model.py:6: DeprecationWarning: the sets module is deprecated
  import sets
Usage: build-apidocs [options]

build-apidocs: error: no such option: --project-base-dir

Change History (3)

comment:1 Changed 8 years ago by Jean-Paul Calderone

You need trunk tip. I'm not sure what resolution this could really have aside from someone packaging a newer version of pydoctor for Debian/Ubuntu. Can we close it?

comment:2 Changed 8 years ago by Jonathan Lange

Resolution: wontfix
Status: newclosed

Sure. I guess I'll document it in the release process.

comment:3 Changed 7 years ago by <automation>

Owner: radix deleted
Note: See TracTickets for help on using tickets.