Opened 5 years ago

Closed 4 years ago

#4327 defect closed duplicate (duplicate)

xmpp streams disconnects when namespaces are not well formed

Reported by: sciasbat Owned by:
Priority: normal Milestone:
Component: words Keywords:
Cc: exarkun Branch:
Author: Launchpad Bug:

Description

Though the behavior is in theory correct, due to other buggy software the xml stream disconnects when receiving tags with trailing spaces in namespaces uris. Example:

<tag xmlns="uri:sometring "/>

A trivial fix has been proposed by Ralph:

http://www.mail-archive.com/twisted-jabber@ik.nu/msg00264.html

Change History (5)

comment:1 Changed 5 years ago by exarkun

  • Cc exarkun added
  • Milestone regular-releases deleted
  • Owner changed from exarkun to ralphm

comment:2 Changed 4 years ago by <automation>

  • Owner ralphm deleted

comment:3 Changed 4 years ago by awclin

  • Owner set to awclin
  • Status changed from new to assigned

comment:4 Changed 4 years ago by awclin

  • Keywords review added
  • Owner awclin deleted
  • Status changed from assigned to new

The fix for #4503 applies (amongst other things) the exact fix outlined in the mailing list thread referenced by the reporter. We have test_namespaceWithWhitespace in words.test.test_domish also, which seems to provide adequate cover for this issue.

Even if this ticket remains open due to the larger (potential) issue around whether we should actively drop support for namespace-well-formedness (some discussion of this is in the linked mailing list thread), I think this one can be closed, and we can open a more relevant one if needs be.

P.S. Not sure on procedure for this kind of resolution to a ticket, so putting it up for review

comment:5 Changed 4 years ago by ralphm

  • Keywords review removed
  • Resolution set to duplicate
  • Status changed from new to closed

Agreed. While the summary of this ticket is slightly misleading (as explained in #4503, the value may have spaces), this ticket can be closed as having been resolved by r29852 and being a (reverse) duplicate of #4503.

The discussion on real namespace-well-formedness could eventually spawn a new ticket.

Note: See TracTickets for help on using tickets.