Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4294 enhancement closed duplicate (duplicate)

trial should run without emitting deprecation warnings relating to Py3k incompatibilities

Reported by: drtimcouper Owned by:
Priority: normal Milestone:
Component: trial Keywords:
Cc: Thijs Triemstra Branch:
Author:

Description

Success is defined as a run of trial over the whole of the test subdirectory before and after the patch is applied.

Attachments (1)

trial3k-4294.patch (898 bytes) - added by drtimcouper 8 years ago.

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by drtimcouper

Attachment: trial3k-4294.patch added

comment:1 Changed 8 years ago by drtimcouper

Status: newassigned

comment:2 Changed 8 years ago by drtimcouper

Keywords: review added
Owner: drtimcouper deleted
Status: assignednew

comment:3 Changed 8 years ago by terrycojones

I couldn't run this (I have Python 2.5.2) but read the patch, which looks fine.

comment:4 Changed 8 years ago by Rotund

Keywords: review removed

With python 2.6, I ran python -3 which trial twisted.test.test_process. The following error was removed: /home/joe/Projects/Twisted/4294/twisted/test/test_process.py:10: DeprecationWarning: The popen2 module is deprecated. Use the subprocess module.

import popen2

Unfortunately, another exception was added: Exception AttributeError: "'NoneType' object has no attribute 'error'" in <bound method Popen.del of <subprocess.Popen object at 0x29dbb90>> ignored

comment:5 Changed 8 years ago by Thijs Triemstra

Cc: Thijs Triemstra added
Resolution: duplicate
Status: newclosed

This is a duplicate of #3431. Can you look into that branch instead?

comment:6 Changed 8 years ago by drtimcouper

FWIW the error shown above does not arise on Windows.

comment:7 Changed 7 years ago by <automation>

Note: See TracTickets for help on using tickets.