Opened 8 years ago

Closed 4 years ago

#4252 enhancement closed duplicate (duplicate)

twisted.web.iweb.IRequest does not have a "content" attribute

Reported by: khorn Owned by:
Priority: normal Milestone:
Component: web Keywords:
Cc: Branch:
Author:

Description

...and it should. There is apparently supposed to be a content attribute which is a file-like object containing the body of the request.

This attribute is a defacto interface, and is used all over the place but is not (AFAICT) part of any Interface, and is not documented in any of the classes' docstrings.

The content attribute should be part of the twisted.web.iweb.IRequest interface, and should also be documented in the twisted.web.http.Request docstring.

Change History (2)

comment:1 Changed 7 years ago by <automation>

Owner: jknight deleted

comment:2 Changed 4 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

#6181 was a duplicate of this. That ticket has been resolved already, though.

Note: See TracTickets for help on using tickets.