Opened 14 years ago

Closed 10 years ago

#423 enhancement closed duplicate (duplicate)

Simpler interface to the conch client code

Reported by: z3p Owned by:
Priority: low Milestone:
Component: conch Keywords:
Cc: Glyph, spiv, itamarst, z3p Branch:
Author:

Description


Change History (6)

comment:1 Changed 14 years ago by z3p

Conch needs to be simpler to use.  Currently, clients require subclassing three
different classes, etc.  Have a simpler interface that's just the basics
(connecting, authenticating with a publickey or a password, creating a channel
or session).

http://www.lag.net/~robey/paramiko/ for an example, perhaps?

comment:2 Changed 14 years ago by itamarst

<glyph> I am always concerned about an API when "simplex" and "ezx" modules
begin proliferating
<glyph> Why can't we just have "conch" and conchimpl" or "complicatedconch" or
something?

comment:3 Changed 14 years ago by z3p

Because the regular API allows for a lot of crazy things that are possible, but
not often used.  Other ways of organizing the conch code are welcome, however. :)

comment:4 Changed 11 years ago by z3p

Priority: normallow

I'm not sure what I want out of this bug, and I'm not sure other people care. I'm leaving it open for the time being, but demoting to low priority.

comment:5 Changed 10 years ago by z3p

Resolution: duplicate
Status: newclosed

It's the wrong order, but I'm marking this as a duplicate of #1975 since I think that's the right way to fix this bug.

comment:6 Changed 7 years ago by <automation>

Owner: z3p deleted
Note: See TracTickets for help on using tickets.