Opened 5 years ago

Closed 4 years ago

#4210 defect closed duplicate (duplicate)

twisted.names.common.extractRecord tries to disconnect a protocol with no transport

Reported by: exarkun Owned by:
Priority: normal Milestone: Twisted-10.0
Component: names Keywords:
Cc: Branch: branches/extractrecord-4210
(diff, github, buildbot, log)
Author: exarkun Launchpad Bug:

Description

Downstream bug report: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=565183

This is another problem introduced by r24401. The supposedly backwards compatible twisted.names.client.Resolver.protocol attribute isn't, once again.

The downstream patch looks correct, for what it's worth, aside from a lack of unit tests.

Change History (3)

comment:1 Changed 4 years ago by exarkun

  • Author set to exarkun
  • Branch set to branches/extractrecord-4210

(In [28684]) Branching to 'extractrecord-4210'

comment:2 Changed 4 years ago by exarkun

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #3998.

comment:3 Changed 4 years ago by <automation>

  • Owner exarkun deleted
Note: See TracTickets for help on using tickets.