Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4135 defect closed duplicate (duplicate)

twisted.trial.runner.TrialRunner._removeSafely is missing a module qualification

Reported by: arkanes Owned by:
Priority: normal Milestone: totally automated release infrastructure
Component: runner Keywords:
Cc: Branch:
Author:

Description

=============================================================================== [ERROR]: twisted.trial.test.test_runner.TestUntilFailure.test_runUntilFailureDecorate

Traceback (most recent call last):

File "C:\Twisted-9.0.0\twisted\trial\test\test_runner.py", line 556, in test_runUntilFailureDecorate

result = self.runner.runUntilFailure(self.test)

File "C:\Twisted-9.0.0\twisted\trial\runner.py", line 896, in runUntilFailure

result = self._runWithoutDecoration(test)

File "C:\Twisted-9.0.0\twisted\trial\runner.py", line 859, in _runWithoutDecoration

oldDir = self._setUpTestdir()

File "C:\Twisted-9.0.0\twisted\trial\runner.py", line 753, in _setUpTestdir

self._removeSafely(testdir)

File "C:\Twisted-9.0.0\twisted\trial\runner.py", line 728, in _removeSafely

newPath = FilePath('_trial_temp_old%s'

exceptions.NameError: global name 'FilePath' is not defined


Change History (3)

comment:1 Changed 8 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Duplicate of #4020

comment:2 Changed 8 years ago by PenguinOfDoom

Milestone: regular-releases

comment:3 Changed 7 years ago by <automation>

Owner: spiv deleted
Note: See TracTickets for help on using tickets.