Opened 5 years ago

Closed 5 years ago

#4113 defect closed duplicate (duplicate)

twisted.web's wsgi.input fails on large or multipart posts

Reported by: rikyu Owned by:
Priority: high Milestone:
Component: web Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

Anytime a request uses a tempfile.TemporaryFile to hold the request body (instead of a StringIO), twisted.web's WSGI _InputStream fails on readline(), since the tempfile doesn't accept None as an argument to readline().

This appears to happen as a result of a multipart/form-data encoded POST request, and potentially also during any large (> 130000 bytes) requests of any method.

Attached patches for wsgi.py and test_wsgi.py.

Attachments (1)

wsgi_input_multipart.diff (3.7 KB) - added by rikyu 5 years ago.
patch for t.w.wsgi and t.w.test.test_wsgi

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by rikyu

patch for t.w.wsgi and t.w.test.test_wsgi

comment:1 Changed 5 years ago by exarkun

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4029

comment:2 Changed 3 years ago by <automation>

  • Owner jknight deleted
Note: See TracTickets for help on using tickets.