Opened 5 years ago

Closed 5 years ago

#4048 defect closed duplicate (duplicate)

imap4.py exception cause Nokia imap client (s60, tested on N97, XM5800) to wait forever

Reported by: Magneto Owned by: Magneto
Priority: normal Milestone:
Component: mail Keywords:
Cc: exarkun Branch:
Author: Launchpad Bug:

Description

Nokia will issue : xxx UID search 1:n, where n is the number of msg the first time it synch with the Server.

Imap4.py has a bug in if the user did not implement the custom search :

def singleSearchStep(self, query, id, msg):

..
f = getattr(self, 'search_' + c)

The fix should be easily done by :

f = getattr(self, 'search_' + c, None)

This avoids an attribute error that will failed the otherwise working routine to
process the message sequence into fetch.

Will do the diff and post the actual fix as suggested in other ticket by exarkun.

Change History (2)

comment:1 Changed 5 years ago by exarkun

Is this a duplicate of #1977? It looks like one to me.

comment:2 Changed 5 years ago by Magneto

  • Resolution set to duplicate
  • Status changed from new to closed

yes it is the same issue.
Maybe just add the nokia s60 imap client as part of the list of affected clients.

Note: See TracTickets for help on using tickets.