Opened 8 years ago

Closed 8 years ago

#4039 enhancement closed duplicate (duplicate)

you should be a ble to close a t.e.adbapi.ConnectionPool even if it was never started.

Reported by: arkanes Owned by: z3p
Priority: normal Milestone:
Component: conch Keywords: adbapi ConnectionPool
Cc: Branch:
Author:

Description

ConnectionPool only gets a ShutdownID if its started. Calling close() on a pool that hasn't been started will throw an exception. It should be a noop instead.

Attachments (1)

connection_pool_example.py (271 bytes) - added by arkanes 8 years ago.
failing testcase

Download all attachments as: .zip

Change History (2)

Changed 8 years ago by arkanes

Attachment: connection_pool_example.py added

failing testcase

comment:1 Changed 8 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Duplicate of #2680.

Note: See TracTickets for help on using tickets.