Opened 8 years ago

Closed 8 years ago

#4034 defect closed duplicate (duplicate)

OpenSSL VC++ client fails to communicate to OpenSSL Twisted Server

Reported by: burslem2001 Owned by:
Priority: highest Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

Hello,

I'm new to twisted and also this website so patience may be required and a deep breath.

I wrote a VC++ client and VC++ server thats communicates using OpenSSL.

I took an example Twisted application that loads a certificate (.pem file) and attempted to connect my client to the server (machine to machine). The VC++ client failed to communicate to the twisted server BIO_new_connect fails. When using the twisted openssl client example. Everything works get with the twisted server.

Can someone from the community recommend a way to debug so that the BIO connects. Not sure if this is a defect.

Much appreciated in advance, Garyc

Attachments (1)

echoserv_ssl.py (858 bytes) - added by burslem2001 8 years ago.
Twisted Test Server

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by burslem2001

Attachment: echoserv_ssl.py added

Twisted Test Server

comment:1 Changed 8 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Duplicate of #4033.

comment:2 Changed 7 years ago by <automation>

Owner: Glyph deleted
Note: See TracTickets for help on using tickets.