Opened 5 years ago

Closed 5 years ago

#3988 defect closed duplicate (duplicate)

python setup.py bdist_rpm fails on CentOS 5.3

Reported by: mlbright Owned by:
Priority: normal Milestone:
Component: core Keywords: build rpmbuild rpm setup distutils
Cc: Branch:
Author: Launchpad Bug:

Description

Running

$ python setup.py bdist_rpm # on CentOS 5.3

fails, with the following error

Processing files: Twisted-8.2.0-1
error: File not found: /var/tmp/Twisted-8.2.0-1-buildroot/usr/lib/python2.4/site-packages/twisted/test/generator_failure_tests.pyc
Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/Twisted-8.2.0-1-buildroot

RPM build errors:

File not found: /var/tmp/Twisted-8.2.0-1-buildroot/usr/lib/python2.4/site-packages/twisted/test/generator_failure_tests.pyc

error: command 'rpmbuild' failed with exit status 1

Change History (3)

comment:1 Changed 5 years ago by mlbright

I got around this by simply deleting twisted/test/generator_failure_tests.py and running the build. Seems to be working.

comment:2 Changed 5 years ago by exarkun

  • Resolution set to duplicate
  • Status changed from new to closed

I'm think this is a duplicate of #1696. Please re-open if I am mistaken.

comment:3 Changed 3 years ago by <automation>

  • Owner glyph deleted
Note: See TracTickets for help on using tickets.