Opened 8 years ago

Closed 8 years ago

#3980 enhancement closed duplicate (duplicate)

some IReactorFDSet docstrings are incomplete

Reported by: Dave Peticolas Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author: davep

Description

In particular, addReader/addWriter don't mention that ILoggingContext is a requirement for their arguments. And doRead/doWrite don't specify that the return value should be used to indicate a closed socket.

Attached patch proposes some docstring text.

Attachments (1)

twisted.patch (1.8 KB) - added by Dave Peticolas 8 years ago.

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by Dave Peticolas

Attachment: twisted.patch added

comment:1 Changed 8 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Um... Duplicate of #3974 (which you filed last week).

comment:2 Changed 7 years ago by <automation>

Owner: Glyph deleted
Note: See TracTickets for help on using tickets.